Call logging delays for Zoho users

Incident Report for Ring.io

Resolved

This incident has been resolved.
Posted Feb 03, 2023 - 16:11 EST

Investigating

Zoho is currently experiencing slow API response times which is resulting in delay with logging calls and contact data enrichment.
Posted Feb 03, 2023 - 14:58 EST