Issue with inbound and outbound calls
Incident Report for Ring.io
Resolved
We are currently experiencing an upstream provider outage that is preventing the Ring.io Web Phone to load.

The Web phone appears to be stuck in the loading screen. Our engineering team is actively seeking service restoration. We apologize for the inconvenience this has caused.
Posted Feb 16, 2022 - 20:01 EST